Elevenfour's Styles and Plugins for WoltLab Suite 3.1 - Compatibility and Update Tutorial


The good news is: Except for one plugin all styles and plugins will receive updates to be able to directly upgrade to WoltLab Suite 3.1. But it could happen that not all styles and plugins have these updates right from the start of WoltLab Suite 3.1 because my day only has 24 hours, too. Sorry for that. Important - the 3.0 versions are NOT compatible with WoltLab Suite 3.1.


Elevenfour Package Server


The one plugin that won't receive an update is the "Elevenfour Package Server" - an update just doesn't make sense here; apart from the fact that it should not be used in production. But there's good news, too: a new beta version for the 3.1 server is available already and be downloaded. But again: it's a beta version so don't use in production.


How to upgrade this plugin:

  • activate maintenance mode
  • create a backup of your site
  • In WoltLab Suite 3.0: uninstall this plugin
  • proceed with the upgrade instructions by WoltLab
  • In WoltLab Suite 3.1: Remove the package server https://elevenfour.net/update/vortex/stable from your ACP (also remove the Elevenfour server unstable and testing if any)
  • In WoltLab Suite 3.1: Install the matching version for WoltLab Suite 3.1 (Tornado), the sever's URL is https://elevenfour.net/update/tornado/stable
  • deactivate maintenance mode


All Other Plugins And Styles


As stated above all other plugins and styles will receive updates and can be upgraded in the upgrading process from WoltLab Suite 3.0 to 3.1. To make this work you have to stick to a certain order, of course.


How to Upgrade

  • activate maintenance mode
  • create a backup of your site (of your community (FTP and database) as well as your own customizations of styles/ plugins, if any)
  • In WoltLab Suite 3.0's ACP: Check Configuration  Package Server if the package server https://elevenfour.net/update/vortex/stable is available. If not: please add it
  • In your ACP click Configuration  Packages  Search for updates to check for updates and install them, if any
  • Add the package server https://elevenfour.net/update/tornado/stable by clicking on Configuration  Package Server 
  • create a backup
  • proceed with the upgrade instructions by WoltLab
  • The styles and plugins will be upgraded while upgrading WoltLab Suite
  • deactivate maintenance mode


These styles and plugins received updates so far (resp. very soon):

  • Basic Green
  • Elevenfour Language Package for Styles
  • Purify
  • Vind


If your style or plugin is not listed above you cannot upgrade yet.


All statements without guarantee.