Compatibility of Our Products with WoltLab Suite 5.3 and End of Life for WoltLab Suite 3.1

The good news is: Compared with WoltLab Suite 5.2 there aren't so many changes that everything might break once you've updated your website to WoltLab Suite 5.3. The bad news: Development of the new version was so quick and I didn't yet find the time to properly test things. So I cannot say yet which of Elevenfour's products can safely be updated to 5.3 and which cannot.

Elevenfour's Plugins

  • Bootstrap Icons for WoltLab Suite - is already compatible
  • Dark Mode for WoltLab Suite ACP - should be compatible, 5.3 is still excluded, needs testing
  • Language package - should be compatible, 5.3 is still excluded, needs testing

Elevenfour's Styles

Until now not a single style has been tested. But from what I've seen I guess that the styles shouldn't have any problems - but 5.3 is still excluded from every style. These styles are planned (not promised) to receive an upgrade for 5.3:

  • Horizon
  • Makani
  • Dark Core
  • Clay
  • Flavius

End of Life WS 3.1 and first announcement for WS 5.2

The release of WoltLab Suite 3.1 also marks the end of life for our products for WoltLab Suite 3.1. By the end of the year the package servers will be deleted so it's no longer possible to download these styles and plugins. By the end of the year our products for WoltLab Suite 5.2 will only receive updates for bug fixes and no more new features. The release of the next WoltLab Suite version (which is either 5.4 or 6.0 - depending on what WoltLab decides) will mark the end of life for our products for WoltLab Suite 5.2.

Package Servers

Package Servers are not yet available. These will be released some time later (they're not yet availabe within the software we use).